View Single Post
Old January 17th, 2012, 10:47 AM   #19
Hawkdriver
Junior Member
 
Join Date: Jan 2012
Posts: 19
Ok, here's the end of the story... Took the car to a local guy I know to have the fuel drained... either way, it needed to be done. It was either contaminant in the fuel, or some component associated with the fuel delivery system. He tapped into the fuel line, put a jumper in the fuel pump relay, and started pumping all of the fuel out of the fuel cell. It drained until it got to 1/4 tank remaining (where I had the problem), and would drain no more fuel at all. Curious. We popped out the battery, opened up the fuel cell, and took a look inside. Looked good. Nothing unusual. Fuel looked clean. Pump was still secured to the floor of the fuel cell where it was supposed to be... So, we pulled the pump out. Here's where it got interesting. The fuel reservoir, which should have been empty as the fuel stopped pumping at 1/4th tank remaining, was completely full of fuel. We popped open the reservoir, and pulled out the pump mechanism.... and looking down into the gas, there was some black plastic debris. We shined a flashlight into the opening at the bottom of the pump, and it was clear to see that the entire bottom row of impeller blades on the pump had broken off.... So the pump could only draw fuel down to the 1/4th remaining point, and would then be unable to drain the reservoir... I popped in a new fuel pump, and not adding a single drop of extra gas, it fired right up, and ran perfectly. So there you have it. I called every Porsche dealership service department in N. Cali., and was given the "hmmm, I've never heard of anything like that... I have no idea what the problem is...." I guess this isn't the typical symptoms for a failing fuel pump... so I thought I would share so that if this happens to anyone else, you'll know exactly what the problem is. Thanks for all the feedback everyone provided! Take care.

Scott
Napa, CA
Hawkdriver is offline   Reply With Quote